iceScrum | "Redirection" issue – iceScrum

iceScrum Forums Discuss on iceScrum

Viewing 6 posts - 1 through 6 (of 6 total)

  • Author
  • #42073



    I’ve installed Icescrum R6 on a RedHat server (using oracle database). After playing with the various config files, the application starts : I see that from the tomcat app manager.

    But when I click on the icescrum link, I have an ERR_TOO_MANY_REDIRECTS error. I can see in the localhost_access_log the following rows - - [15/Dec/2016:17:29:52 +0000] "GET /icescrum/errors/database HTTP/1.1" 302 - - - [15/Dec/2016:17:29:52 +0000] "GET /icescrum/setup HTTP/1.1" 302 -

    I’m not expert of tomcat/server managing and I don’t know where to find the cause of this problem.

    Any idea would be welcome.


    Vincent Barrier


    You must use the same URL in your browser to access to iceScrum than the one you have set in your config.groovy with the

    grails.serverURL = “http://YOUR_URL_TO_ICESCRUM”

    by default it is http://localhost:8080/icescrum (or another context name you choose)



    Thanks for your answer.

    I set this row in the config.groovy

    I have this connector in the server.xml file :
    <Connector port=”8080″ protocol=”org.apache.coyote.http11.Http11NioProtocol”
    connectionTimeout=”2000″ maxThreads=”500″ URIEncoding=”UTF-8″/>

    I try with this too..
    <Connector port=”8080″ URIEncoding=”UTF-8″
    connectionUploadTimeout=”36000000″ disableUploadTimeout=”false”
    connectionTimeout=”60000″ redirectPort=”8443″ />
    It’s a mixed connector from the documentation of Icescrum and the connector I used on an ubuntu server.
    But no effects.



    May be another stupid question with no relationship with the initial problem but : may I use Oracle with the Icescrum community version ?
    I have this message in the tomcat status :
    Error: the Oracle support requires an iceScrum Pro license


    Vincent Barrier


    Sorry for not having followed up on your previous message, with holidays and our work on iceScrum 7 we had very little time to dedicate the community forum lately.

    Is your “TOO_MANY_REDIRECTS” problem solved?

    Regarding your second question, all other DBMS are included in Community but Oracle required a lot of specific work to be supported so it is not available in Community, it’s only available with a Pro license.

    By the way, no question is stupid, feel free to ask we are glad to help!



    Thanks for your answer !

    Unfortunately the problem is not solved.

    So I wonder if the problem was not due to the use of Oracle ?
    Note that the tables appear to be automaticaly well created.
    Furthermore, note that I thought I downloaded the “pro version”

Viewing 6 posts - 1 through 6 (of 6 total)

The forum ‘Installation’ is closed to new topics and replies.