iceScrum | Icescrum didn't start – iceScrum

iceScrum Forums Discuss on iceScrum

Viewing 4 posts - 1 through 4 (of 4 total)

  • Author
  • #14787


    Hi, i’m trying to install a icescrum server but when i enter to the url http://localhost:8081/icescrum, I get a 404 error from tomcat. I followed this steps to make the install:

    1. I Install Java (jdk-7u79-linux-x64), and I set the JAVA_HOME.
    2. I delete the file tomcat-jdbc.jar from /lib folder.
    3. I add to the file server.xml:

    <Connector port="8081" protocol="org.apache.coyote.http11.Http11NioProtocol"
               connectionTimeout="2000" maxThreads="500" URIEncoding="UTF-8"/>

    4. I try to use script, but that didn’t works, so i modify the file adding the next lines:

    export CATALINA_OPTS="$CATALINA_OPTS -Dicescrum.log.dir=/opt/tomcat/apache-tomcat-7.0.62/logs"
    export CATALINA_OPTS="$CATALINA_OPTS -XX:MaxPermSize=256m"
    export CATALINA_OPTS="$CATALINA_OPTS -Xmx512m"
    export CATALINA_OPTS="$CATALINA_OPTS -server"
    export CATALINA_OPTS="$CATALINA_OPTS -Duser.timezone=UTC"
    export CATALINA_OPTS="$CATALINA_OPTS -Dicescrum_config_location=/home/deb/icescrum/config.groovy”
    export CATALINA_OPTS="$CATALINA_OPTS -Djava.awt.headless=true"

    5. I create a file named config.groovy with this data:

    icescrum.project.import.enable = true
    icescrum.project.export.enable = true
    icescrum.project.creation.enable = true
    icescrum.project.private.enable = true
    icescrum.project.private.default = false = false
    icescrum.gravatar.enable = false
    icescrum.registration.enable = false
    icescrum.login.retrieve.enable = true
    icescrum.auto_follow_productowner = true
    icescrum.auto_follow_stakeholder  = true
    icescrum.auto_follow_scrummaster  = true = ""
    icescrum.alerts.subject_prefix = "[icescrum]"
    icescrum.alerts.enable = true
    icescrum.alerts.default.from = ""
    icescrum.attachments.enable = true
    grails.serverURL = "http://localhost:8081/icescrum"
    icescrum.debug.enable = false
    icescrum.securitydebug.enable = false
    icescrum.baseDir = "/home/icescrum"
    icescrum.cors.enable = true
    icescrum.cors.allow.origin.regex = "*" = ""
    grails.mail.port = 465
    grails.mail.username = ""
    grails.mail.password = "xxx"
    grails.mail.props = ["mail.smtp.auth":"true",

    But after run the, i only see this error:

    ERROR util.JDBCExceptionReporter - Column not found: TEXT_AS in statement [SELECT id, text_as, textican, text_to FROM icescrum2_story WHERE text_as IS NOT NULL OR textican IS NOT NULL OR text_to IS NOT NULL]

    The complete catalina.out are available at:
    and the icescrum.log at:

    What i’m missing?




    Vincent Barrier


    Your configuration seems correct. The error about TEXT_AS is caught by iceScrum and you shouldn’t care about.

    But as I see this line:

    Jul 06, 2015 5:30:06 PM org.apache.coyote.AbstractProtocol start
    INFO: Starting ProtocolHandler ["http-bio-8080"]

    Did you remove the original connector in the server.xml file? (and replace it by the one with Nio)

    Could you try to open iceScrum on the url: http://localhost:8080/icescrum ? (notice 8080 port)

    In any case you must remove the connector and restart Tomcat. It should help.




    Hi Vicent, thanks for your response. I remove the original connector in the server.xml file but i have the same problem, I have a war of icescrum (version R6_11), if I put that war at the webapps folder it works with the same configuration. so i don’t know what is happening, My OS is debian 8, the apache tomcat version is 7.0.62, and the icescrum version is the R6_14.1.


    Nicolas Noullet

    Hi Xavier,

    Thanks for the update. There must be another error in the logs. You can enable more verbose logging by changing this line in config.groovy:
    icescrum.debug.enable = true

    Then, you can check the content of icescrum.log and catalina.out and look for an error (the TEXT_AS error excluded, you can check the common errors in the documentation:

Viewing 4 posts - 1 through 4 (of 4 total)

The forum ‘Installation’ is closed to new topics and replies.