iceScrum | Awful situation after setup error... – iceScrum

iceScrum Forums Discuss on iceScrum

Viewing 4 posts - 1 through 4 (of 4 total)

  • Author
  • #15472


    Hi All,

    I’m trying to setup iceScrum on a windows 2008 R2 server (64bits).
    I already have a Tomcat v7, so I try to deploy iceScrum on this server.

    All work fine except that I do a mistake during configuration, tomcat user didn’t have authorisation to write in config file (groovy file). At end of icescrum setup, system say to me : Error during save.

    All is OK at this step. he take to me some minutes to understand where is the issue, so I stop tomcat server and solve issue. When I want to restart iceScrum, I didn’t get anymore setup of application, I just go directly on application with error message saying to me that I have to change “localhost”.

    How I can get this setup again ? I try to undeploy and deploy it again, without any success…

    I also try to create my own config.groovy file, but in this case, I get the following error :

    Grails Runtime Exception
    Error Details
    Error 500: Cannot get property 'preferences' on null object
    Servlet: grails
    URI: /icescrum/grails/setup/index.dispatch
    Exception Message: Cannot get property 'preferences' on null object 
    Caused by: Cannot get property 'preferences' on null object 
    Class: GrailsFragmentCachingFilter 
    At Line: [66] 
    Code Snippet:
    action: index
    controller: setup
    Stack Trace
    java.lang.NullPointerException: Cannot get property 'preferences' on null object
    	at IceScrumFilters$_closure1_closure8_closure20.doCall(IceScrumFilters.groovy:139)
    	at IceScrumFilters$_closure1_closure8_closure20.doCall(IceScrumFilters.groovy)
    	at grails.plugin.springcache.web.GrailsFragmentCachingFilter.doFilter(GrailsFragmentCachingFilter.groovy:66)
    	at net.sf.ehcache.constructs.web.filter.Filter.doFilter(
    	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    	at java.util.concurrent.ThreadPoolExecutor$ Source)
    	at Source)

    Please found below my groovy file :

    icescrum.project.import.enable = true
    icescrum.project.export.enable = true
    icescrum.project.creation.enable = true
    icescrum.project.private.enable = true
    icescrum.project.private.default = false
    icescrum.gravatar.enable = false
    icescrum.registration.enable = true
    icescrum.invitation.enable = false
    icescrum.login.retrieve.enable = true
    icescrum.auto_follow_productowner = false
    icescrum.auto_follow_stakeholder  = false
    icescrum.auto_follow_scrummaster  = false = ""
    icescrum.alerts.subject_prefix = "[icescrum]"
    icescrum.alerts.enable = true
    icescrum.alerts.default.from = ""
    icescrum.attachments.enable = true
    grails.serverURL = ""
    icescrum.debug.enable = false
    icescrum.securitydebug.enable = false
    icescrum.cors.enable = false
    dataSource.dialect = "org.hibernate.dialect.MySQL5InnoDBDialect"
    dataSource.driverClassName = "com.mysql.jdbc.Driver"
    dataSource.url = "jdbc:mysql://localhost:3306/icescrum?useUnicode=true&characterEncoding=utf8"
    dataSource.username = "******"
    dataSource.password = "******"

    Any help is highly welcome.

    Thank in advance.



    Nicolas Noullet

    Hi Gaël,

    There is probably a bug: the setup should be started again if the file creation fails. We will investigate.

    The fact that the setup must be shown or not depends on the database. If your config has not been taken into account then I guess that the default database is used, which is written in prodDba.* files. I recommend that you start by deleting them to ensure that the setup is shown again at next startup.

    Then, the “localhost” warning indicates that your config.groovy file is not taken into account. If you want it to be used then I recommend that you move it to a .icescrum directory in the home directory of the user who starts icescrum. This is the default place where icescrum looks for it if you don’t provide the path explicitly.

    If your config.groovy file is found then its values will be used by default in the setup. Otherwise, you will have to enter them again. If you come across another permission issue when saving it then you don’t have to restart Tomcat, just try fixing the permission an save again.




    Hi Nicolas,

    Thank you very much for this quick answer. I finally solve my issue by deleting my user profil on server, and recreat it “blank”…

    After this, setup show again and I can setup my server.

    So, yes, there is something around the default location of groovy file… But what is a little strange is : whithout changing anything in my configuration, the new groovy file was created in the correct location (defined in java option, not in user profil).

    But ok, all work fine now. Thank you very much for this great tools (I already use it in test since some time, now we start to use it in production)…

    Have a nice day.



    Nicolas Noullet


    Glad to know that it works fine now. The user deletion has probably also deleted the default DB files that were preventing the setup to show up.

    Anyway, we will investigate further to understand and fix the issue you came across.

    Thanks for your enthusiastic feedback, have a nice day too 🙂


Viewing 4 posts - 1 through 4 (of 4 total)

The forum ‘Installation’ is closed to new topics and replies.